• Arun Nukula

Resource not found for the segment 'VirtualMachineExts'

Requests fail during allocation phase with exception


catalina.out ( vRA Appliance )

com.vmware.vcac.iaas.service.impl.BaseCompositionRequestServiceImpl.processAsyncAllocationTask:737 - Allocation request [Composition RequestId: [XXXX-XXX], CompTypeId: [Infrastructure.CatalogItem.Machine.Virtual.vSphere], BlueprintId: [XXXX-XXX], CompId: [VirtualMachine], BlueprintRequestId:[XXXX-XXX], RootCafeRequestId: [XXXX-XXX], SubtenantId: [XXXX-XXX]with binding id [XXXX-XXX] failed with [HTTP/1.1 404 Not Found : <?xml version="1.0" encoding="utf-8"?><m:error xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"><m:code /><m:message xml:lang="en-US">Resource not found for the segment 'VirtualMachineExts'.</m:message></m:error>].

org.odata4j.exceptions.NotFoundException: HTTP/1.1 404 Not Found : <?xml version="1.0" encoding="utf-8"?><m:error xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"><m:code /><m:message xml:lang="en-US">Resource not found for the segment 'VirtualMachineExts'.</m:message></m:error>

at org.odata4j.exceptions.NotFoundException$Factory.createException(NotFoundException.java:46) ~[odata4j-core-7.3.1-SNAPSHOT.jar:?]

at org.odata4j.exceptions.NotFoundException$Factory.createException(NotFoundException.java:37) ~[odata4j-core-7.3.1-SNAPSHOT.jar:?]

at org.odata4j.exceptions.ODataProducerExceptions.create(ODataProducerExceptions.java:92) ~[odata4j-core-7.3.1-SNAPSHOT.jar:?]

at org.odata4j.consumer.ErrorMessageParser.parse(ODataCxfClientEx.java:383) ~[platform-odata4j-7.3.1-SNAPSHOT.jar:?]

at org.odata4j.consumer.ODataCxfClientEx.doRequest(ODataCxfClientEx.java:308) ~[platform-odata4j-7.3.1-SNAPSHOT.jar:?]

at org.odata4j.consumer.AbstractODataClient.getEntity(AbstractODataClient.java:65) ~[odata4j-core-7.3.1-SNAPSHOT.jar:?]




Repository.log


[UTC:2019-05-16 05:13:44 Local:2019-05-16 13:13] [Error]: [sub-thread-Id="27" context="" token=""] System.Data.Services.DataServiceException: Resource not found for the segment 'VirtualMachineExts'.

at System.Data.Services.Providers.DataServiceExecutionProviderWrapper.GetSingleResultFromRequest(SegmentInfo segmentInfo)

at System.Data.Services.DataService`1.CompareETagAndWriteResponse(RequestDescription description, IDataService dataService, IODataResponseMessage responseMessage)

at System.Data.Services.DataService`1.SerializeResponseBody(RequestDescription description, IDataService dataService, IODataResponseMessage responseMessage)

at System.Data.Services.DataService`1.HandleRequest()



Looking at the blueprint configuration , user configured build information to be


Blueprint Type : Server

Action : Create

Provisioning Workflow : BasicVmWorkflow


They were using component profiles to choose different OS types ( 2008 R2 , 2012 & 2016 ) when submitting request using service catalog


When we verified available Image component profiles , we found that the template field was blank.


When we mapped appropriate templates to their corresponding value sets then provisioning started to work as expected



301 views

Recent Posts

See All

Subscribe Now

  • Twitter
  • Facebook Social Icon

Copyright © 2019 nukescloud