• Arun Nukula

Failures during vRA patch installation


Was working on a brand new installation of vRA 7.4 where we were attempting to patch with the latest one under KB 56618

While implementing , it was throwing a straight exception right after the upload's completed

Below was the exception in /var/log/vmware/vcac/vcac-config.log


But actual exception on why the failure was under IAAS node's Management Agent All.log


Failure was seen because IAAS was unable to fetch binaries from vRA Appliance

On vRA Virtual Appliance nodes, open /etc/hosts file, find the entry for IPv4 loopback IP Address (127.0.0.1). Make sure that the ‘Fully Qualified Domain Name’ of the node immediately follows ‘127.0.0.1’, before ‘localhost’. ** Example: 127.0.0.1 FQDN_HOSTNAME_OF_NODE localhost

In our case it was as below

/etc/hosts was

# VAMI_EDIT_BEGIN

# Generated by Studio VAMI service. Do not modify manually.

127.0.0.1 localhost

10.36.19.50 vraapp01.pslab.org vraapp01

127.0.0.1 vraapp01.pslab.org load-balancer-host

# VAMI_EDIT_END

Actually it should be

# VAMI_EDIT_BEGIN

# Generated by Studio VAMI service. Do not modify manually.

127.0.0.1 vraapp01.pslab.org vraapp01 localhost

::1 vraapp01.pslab.org vraapp01 localhost ipv6-localhost ipv6-loopback

# VAMI_EDIT_END

127.0.0.1 localhost.localdom

127.0.0.1 vrava-lb.pslab.org load-balancer-host

This change has been documented in the Patch KB as well.

Here are the screenshots for failure and successful patch installation



#vRealizeAutomation

0 views

Subscribe Now

  • Twitter
  • Facebook Social Icon

Copyright © 2019 nukescloud